OiO.lk Community platform!

Oio.lk is an excellent forum for developers, providing a wide range of resources, discussions, and support for those in the developer community. Join oio.lk today to connect with like-minded professionals, share insights, and stay updated on the latest trends and technologies in the development field.
  You need to log in or register to access the solved answers to this problem.
  • You have reached the maximum number of guest views allowed
  • Please register below to remove this limitation

Windows PC not synchronising Time with Ubuntu PC

  • Thread starter Thread starter gd1925
  • Start date Start date
G

gd1925

Guest
I'm facing an issue with time synchronization between my Windows PC and an Ubuntu NTP server. Here's my setup and what I've tried so far:

Setup: Ubuntu PC:

  • IP Address: 192.168.1.4
  • NTP Server: ntpd running and synchronized with multiple servers.
  • Firewall (UFW): Disabled

Windows PC:

  • IP Address: 192.168.1.5
  • Windows Time service (w32time): Running
  • Firewall: Added rule to allow UDP traffic on port 123

Steps Taken: Ubuntu NTP Configuration:

Added the following lines to

/etc/ntp.conf

:

Code:
restrict 192.168.1.0 mask 255.255.255.0 nomodify notrap
server 0.ubuntu.pool.ntp.org iburst
server 1.ubuntu.pool.ntp.org iburst
server 2.ubuntu.pool.ntp.org iburst
server 3.ubuntu.pool.ntp.org iburst

Restarted NTP service : (sudo systemctl restart ntp). Verified NTP status (ntpq -p) shows synchronization with upstream servers. Windows Configuration:

Added firewall rule to allow NTP traffic:

netsh advfirewall firewall add rule name="Allow NTP" protocol=udp dir=in localport=123 action=allow Configured NTP server:

w32tm /config /manualpeerlist:"192.168.1.4" /syncfromflags:manual /reliable:YES /update

Restarted Windows Time service:

net stop w32time net start w32time

Resynchronization:

w32tm /resync

Issue: Despite these configurations, my Windows PC continues to use the local CMOS clock as the time source. The output of w32tm /query /status shows:

Source: Local CMOS Clock ReferenceID: 0x4C4F434C (LOCL)

Running

w32tm /stripchart /computer:192.168.1.4 /samples:5 /dataonly

results in timeout errors:

Tracking 192.168.1.4 [192.168.1.4:123]. The current time is ...: 07:43:00, error: 0x800705B4

...

Additional Information:

  1. I can ping the Ubuntu PC from the Windows PC without any issues.
  2. The Ubuntu NTP server is synchronized with its upstream servers.
  3. The firewall rule on the Windows PC is confirmed to be in place and active.

Request: Any advice on why the Windows PC isn't syncing with the Ubuntu NTP server and continues to use the local CMOS clock? Are there additional configurations or diagnostics I should try? Thank you.
<p>I'm facing an issue with time synchronization between my Windows PC and an Ubuntu NTP server. Here's my setup and what I've tried so far:</p>
<p>Setup:
Ubuntu PC:</p>
<ul>
<li>IP Address: 192.168.1.4</li>
<li>NTP Server: ntpd running and synchronized with multiple servers.</li>
<li>Firewall (UFW): Disabled</li>
</ul>
<p>Windows PC:</p>
<ul>
<li>IP Address: 192.168.1.5</li>
<li>Windows Time service (w32time): Running</li>
<li>Firewall: Added rule to allow UDP traffic on port 123</li>
</ul>
<p>Steps Taken:
Ubuntu NTP Configuration:</p>
<p>Added the following lines to</p>
<blockquote>
<p>/etc/ntp.conf</p>
</blockquote>
<p>:</p>
<pre><code>restrict 192.168.1.0 mask 255.255.255.0 nomodify notrap
server 0.ubuntu.pool.ntp.org iburst
server 1.ubuntu.pool.ntp.org iburst
server 2.ubuntu.pool.ntp.org iburst
server 3.ubuntu.pool.ntp.org iburst
</code></pre>
<p>Restarted NTP service : (sudo systemctl restart ntp).
Verified NTP status (ntpq -p) shows synchronization with upstream servers.
Windows Configuration:</p>
<p>Added firewall rule to allow NTP traffic:</p>
<p>netsh advfirewall firewall add rule name="Allow NTP" protocol=udp dir=in localport=123 action=allow
Configured NTP server:</p>
<blockquote>
<p>w32tm /config /manualpeerlist:"192.168.1.4" /syncfromflags:manual
/reliable:YES /update</p>
</blockquote>
<p>Restarted Windows Time service:</p>
<blockquote>
<p>net stop w32time
net start w32time</p>
</blockquote>
<p>Resynchronization:</p>
<blockquote>
<p>w32tm /resync</p>
</blockquote>
<p>Issue:
Despite these configurations, my Windows PC continues to use the local CMOS clock as the time source. The output of w32tm /query /status shows:</p>
<blockquote>
<p>Source: Local CMOS Clock
ReferenceID: 0x4C4F434C (LOCL)</p>
</blockquote>
<p>Running</p>
<blockquote>
<p>w32tm /stripchart /computer:192.168.1.4 /samples:5 /dataonly</p>
</blockquote>
<p>results in timeout errors:</p>
<blockquote>
<p>Tracking 192.168.1.4 [192.168.1.4:123]. The current time is ...:
07:43:00, error: 0x800705B4</p>
</blockquote>
<p>...</p>
<p>Additional Information:</p>
<ol>
<li>I can ping the Ubuntu PC from the Windows PC without any issues.</li>
<li>The Ubuntu NTP server is synchronized with its upstream servers.</li>
<li>The firewall rule on the Windows PC is confirmed to be in place and active.</li>
</ol>
<p>Request:
Any advice on why the Windows PC isn't syncing with the Ubuntu NTP server and continues to use the local CMOS clock? Are there additional configurations or diagnostics I should try? Thank you.</p>
Continue reading...
 
Top