OiO.lk Community platform!

Oio.lk is an excellent forum for developers, providing a wide range of resources, discussions, and support for those in the developer community. Join oio.lk today to connect with like-minded professionals, share insights, and stay updated on the latest trends and technologies in the development field.
  You need to log in or register to access the solved answers to this problem.
  • You have reached the maximum number of guest views allowed
  • Please register below to remove this limitation

VSCode Jupyter extension display wrong version of Python interpreter

  • Thread starter Thread starter sicheng mao
  • Start date Start date
S

sicheng mao

Guest
I'm encountering a very weird issue, as the following picture shows. I can select my IPython kernel from a virtual environment but it displays as micromamba (Python 3.1.-1) while it should be 3.12.0. This makes other extensions (e.g. Pylance) disabled since it's an unsupported Python environment.

What can I do?

screenshot showing the running kernel
<p>I'm encountering a very weird issue, as the following picture shows. I can select my IPython kernel from a virtual environment but it displays as <code>micromamba (Python 3.1.-1)</code> while it should be 3.12.0. This makes other extensions (e.g. Pylance) disabled since <a href="https://github.com/microsoft/vscode-jupyter/wiki/Using-unsupported-Python-Environments" rel="nofollow noreferrer">it's an unsupported Python environment</a>.</p>
<p>What can I do?</p>
<p><a href="https://i.sstatic.net/mLg3q3WD.png" rel="nofollow noreferrer"><img src="https://i.sstatic.net/mLg3q3WD.png" alt="screenshot showing the running kernel" /></a></p>
 

Latest posts

Online statistics

Members online
0
Guests online
3
Total visitors
3
Top