OiO.lk Community platform!

Oio.lk is an excellent forum for developers, providing a wide range of resources, discussions, and support for those in the developer community. Join oio.lk today to connect with like-minded professionals, share insights, and stay updated on the latest trends and technologies in the development field.
  You need to log in or register to access the solved answers to this problem.
  • You have reached the maximum number of guest views allowed
  • Please register below to remove this limitation

Tizen AVPlay Player Can’t Play MP4 PLAYER_ERROR_CONNECTION_FAILED

  • Thread starter Thread starter FathonaAji
  • Start date Start date
F

FathonaAji

Guest
I need to play a mp4 video and the source of video is on my cloud server. I try to play using video tag <video></video> it’s work correctly the video is playing. But when i try to using AVPlay API it’s throw the error PLAYER_ERROR_CONNECTION_FAILED when calling to prepare. This is my code

Code:
    webapis.avplay.open("https://preskripsi.com/assets/net.mp4");
    webapis.avplay.setDisplayRect(0, 0, 1920, 1080);
    webapis.avplay.setDisplayMethod(
      "PLAYER_DISPLAY_MODE_AUTO_ASPECT_RATIO"
    );
    webapis.avplay.setListener(listener);
    webapis.avplay.prepareAsync(function () {
      webapis.avplay.play();
    });

i’ve been put this on config.xml but it’s still not working

Code:
<access origin="*" subdomains="true"></access>
<tizen:privilege name="http://tizen.org/privilege/internet"/>
<tizen:privilege name="http://tizen.org/privilege/tv.window"/>

and i try to put this on config.xml

Code:
<tizen:privilege name="http://developer.samsung.com/privilege/avplay" />

but still not working

please help me, thanks.

<p>I need to play a mp4 video and the source of video is on my cloud server. I try to play using video tag <code><video></video></code> it’s work correctly the video is playing. But when i try to using AVPlay API it’s throw the error PLAYER_ERROR_CONNECTION_FAILED when calling to prepare. This is my code</p>
<pre><code> webapis.avplay.open("https://preskripsi.com/assets/net.mp4");
webapis.avplay.setDisplayRect(0, 0, 1920, 1080);
webapis.avplay.setDisplayMethod(
"PLAYER_DISPLAY_MODE_AUTO_ASPECT_RATIO"
);
webapis.avplay.setListener(listener);
webapis.avplay.prepareAsync(function () {
webapis.avplay.play();
});
</code></pre>
<p>i’ve been put this on config.xml but it’s still not working</p>
<pre><code><access origin="*" subdomains="true"></access>
<tizen:privilege name="http://tizen.org/privilege/internet"/>
<tizen:privilege name="http://tizen.org/privilege/tv.window"/>

</code></pre>
<p>and i try to put this on config.xml</p>
<pre><code><tizen:privilege name="http://developer.samsung.com/privilege/avplay" />
</code></pre>
<p>but still not working</p>
<p>please help me, thanks.</p>
 

Latest posts

Top