OiO.lk Community platform!

Oio.lk is an excellent forum for developers, providing a wide range of resources, discussions, and support for those in the developer community. Join oio.lk today to connect with like-minded professionals, share insights, and stay updated on the latest trends and technologies in the development field.
  You need to log in or register to access the solved answers to this problem.
  • You have reached the maximum number of guest views allowed
  • Please register below to remove this limitation

Strapi showing latest node version which is not even installed on my computer

  • Thread starter Thread starter Soumyadip Adhikari
  • Start date Start date
S

Soumyadip Adhikari

Guest
0

I am trying to create a new strapi project in my api folder for an ecommerce website project. However no matter what I do to try to change the node version using nvm I still get this error (that it is not compatible to the current version). As you can see below I literally just used nvm to change the node version to 20.0.0 and I got confirmation I was currently using it. Also you can see on my nvm list command that 21.2.0 isn't even installed. I am confused and also a beginner. Am I using nvm wrong? Do I have to delete some previous folder that is somehow making my project think I am using 21.2.0? I am very confused and would appreciate any help.

[email protected] PS C:\Users\liamt\Desktop\ecommerce-app\api> nvm current v20.11.0 PS C:\Users\liamt\Desktop\ecommerce-app\api> nvm ls

Code:
20.9.0
20.5.0
20.0.0

PS C:\Users\liamt\Desktop\ecommerce-app\api> nvm use 20.0.0 Now using node v20.0.0 (64-bit) PS C:\Users\liamt\Desktop\ecommerce-app\api> npx create-strapi-app@latest .
(node:14736) [DEP0040] DeprecationWarning: The punycode module is deprecated. Please use a userland alternatiternative instead. (Use node --trace-deprecation ... to show where the warning was created) ? Choose your installation type Custom (manual settings) You are running Node.js 21.2.0 Strapi requires Node.js >=18.0.0 <=20.x.x Please make sure to use the right version of Node. PS C:\Users\liamt\Desktop\ecommerce-app\api> I tried to change the version of nod using nvm and it appeared to change however I still have the same error.

I updated the node version to 20 but not working although showing on cmd

<p>0</p>
<p>I am trying to create a new strapi project in my api folder for an ecommerce website project. However no matter what I do to try to change the node version using nvm I still get this error (that it is not compatible to the current version). As you can see below I literally just used nvm to change the node version to 20.0.0 and I got confirmation I was currently using it. Also you can see on my nvm list command that 21.2.0 isn't even installed. I am confused and also a beginner. Am I using nvm wrong? Do I have to delete some previous folder that is somehow making my project think I am using 21.2.0? I am very confused and would appreciate any help.</p>
<p>[email protected]
PS C:\Users\liamt\Desktop\ecommerce-app\api> nvm current
v20.11.0
PS C:\Users\liamt\Desktop\ecommerce-app\api> nvm ls</p>
<pre><code>20.9.0
20.5.0
20.0.0
</code></pre>
<p>PS C:\Users\liamt\Desktop\ecommerce-app\api> nvm use 20.0.0
Now using node v20.0.0 (64-bit)
PS C:\Users\liamt\Desktop\ecommerce-app\api> npx create-strapi-app@latest .<br />
(node:14736) [DEP0040] DeprecationWarning: The <code>punycode</code> module is deprecated. Please use a userland alternatiternative instead.
(Use <code>node --trace-deprecation ...</code> to show where the warning was created)
? Choose your installation type Custom (manual settings)
You are running Node.js 21.2.0
Strapi requires Node.js >=18.0.0 <=20.x.x
Please make sure to use the right version of Node.
PS C:\Users\liamt\Desktop\ecommerce-app\api>
I tried to change the version of nod using nvm and it appeared to change however I still have the same error.</p>
<p>I updated the node version to 20 but not working although showing on cmd</p>
 

Latest posts

Top