OiO.lk Community platform!

Oio.lk is an excellent forum for developers, providing a wide range of resources, discussions, and support for those in the developer community. Join oio.lk today to connect with like-minded professionals, share insights, and stay updated on the latest trends and technologies in the development field.
  You need to log in or register to access the solved answers to this problem.
  • You have reached the maximum number of guest views allowed
  • Please register below to remove this limitation

Solve conda-libmamba-solver (libarchive.so.19) error after updating conda to 23.11.0 without reinstalling conda?

  • Thread starter Thread starter Homero Esmeraldo
  • Start date Start date
H

Homero Esmeraldo

Guest
After conda update, I am getting the error below after running $ conda, even after setting the solver to classic (using conda config --set solver classic):

Code:
Error while loading conda entry point: conda-libmamba-solver (libarchive.so.19: cannot open shared object file: No such file or directory)

I have conda 23.11.0.

On Github there is an issue https://github.com/conda/conda-libmamba-solver/issues/283 in which they mention that if libarchive and libmamba come from the same channel, it should be solved.

But when I reinstall libarchive using channel main, it doesn't update.

Does anyone know how to solve this? I do not want to reinstall Conda from scratch.

Similar links online that do not solve the problem:

<p>After conda update, I am getting the error below after running <code>$ conda</code>, even after setting the solver to classic (using <code>conda config --set solver classic</code>):</p>
<pre><code>Error while loading conda entry point: conda-libmamba-solver (libarchive.so.19: cannot open shared object file: No such file or directory)
</code></pre>
<p>I have conda 23.11.0.</p>
<p>On Github there is an issue <a href="https://github.com/conda/conda-libmamba-solver/issues/283" rel="noreferrer">https://github.com/conda/conda-libmamba-solver/issues/283</a> in which they mention that if <code>libarchive</code> and <code>libmamba</code> come from the same channel, it should be solved.</p>
<p><strong>But when I reinstall <code>libarchive</code> using channel <code>main</code>, it doesn't update.</strong></p>
<p>Does anyone know how to solve this? <strong>I do not want to reinstall Conda from scratch</strong>.</p>
<p>Similar links online that do not solve the problem:</p>
<ul>
<li><a href="https://stackoverflow.com/questions...-get-warning-libmamba-could-not-parse-state-f">After installing libmamba solver i get `warning libmamba Could not parse state file`</a></li>
<li><a href="https://stackoverflow.com/questions...ile-installing-libraries-in-conda-environment">How to Fix Entry Point Not Found while installing libraries in conda environment</a></li>
<li><a href=" " rel="noreferrer"> </a></li>
</ul>
 

Latest posts

S
Replies
0
Views
1
Safwan Aipuram
S
Top