OiO.lk Community platform!

Oio.lk is an excellent forum for developers, providing a wide range of resources, discussions, and support for those in the developer community. Join oio.lk today to connect with like-minded professionals, share insights, and stay updated on the latest trends and technologies in the development field.
  You need to log in or register to access the solved answers to this problem.
  • You have reached the maximum number of guest views allowed
  • Please register below to remove this limitation

pip config encode asterisk [*] in password

  • Thread starter Thread starter Ale
  • Start date Start date
A

Ale

Guest
I'm trying to set up pip in Google Cloud. I'm in Vertex AI >> Workbench.

I'm going through the following steps

Code:
export 'HTTPS_PROXY'='http://proxyserv.xxx/'
export 'NO_PROXY'='.googleapis.com'

python -m venv env  
source env/bin/activate

Then I run the following by putting my USER and PASSWORD:

Code:
pip config set global.trusted-host "artifacts.cloud.xxx.com"  
pip config set global.index-url 'https://USER:[email protected]/artifactory/api/pypi/pypi-remote/simple/'  
pip config set global.extra-index-url 'https://USER:[email protected]/artifactory/api/pypi/arq-almaas-pypi-local/simple/'

Then when I run pip install ipykernel I get the following error and warning:

Code:
(env) jupyter@vm-53721647-831e-4ef4-bb83-5507bc6d8b55:~/formacion_gcp_ml/DATAnowCampus_ML_IA_material/Vertex$ pip install ipykernel
Looking in indexes: https://USER:****@artifacts.cloud.xxx.com/artifactory/api/pypi/pypi-remote/simple, https://USER:****@artifacts.cloud.xxx.com/artifactory/api/pypi/arq-almaas-pypi-local/simple/
WARNING: 401 Error, Credentials not correct for https://artifacts.cloud.xxx.com/artifactory/api/pypi/pypi-remote/simple/ipykernel/
ERROR: Could not find a version that satisfies the requirement ipykernel (from versions: none)
ERROR: No matching distribution found for ipykernel

I thought that one possible reason is that my PASSWORD has an asterisk inside, such as abcdefg*, so I tried to following encodings:

  • USER:abcdefg/*
  • USER:abcdefg\*
  • USER:abcdefg'/*'
  • USER:abcdefg'\*'
  • USER:abcdefg%2A

But nothing.

In the documentation I get that %2A should work: https://pip.pypa.io/en/stable/topics/authentication/

Any workaround? Changing password is quite a problem right now.

Please let me know is more information is needed.
<p>I'm trying to set up pip in Google Cloud. I'm in Vertex AI >> Workbench.</p>
<p>I'm going through the following steps</p>
<pre><code>export 'HTTPS_PROXY'='http://proxyserv.xxx/'
export 'NO_PROXY'='.googleapis.com'

python -m venv env
source env/bin/activate
</code></pre>
<p>Then I run the following by putting my USER and PASSWORD:</p>
<pre><code>pip config set global.trusted-host "artifacts.cloud.xxx.com"
pip config set global.index-url 'https://USER:[email protected]/artifactory/api/pypi/pypi-remote/simple/'
pip config set global.extra-index-url 'https://USER:[email protected]/artifactory/api/pypi/arq-almaas-pypi-local/simple/'
</code></pre>
<p>Then when I run <code>pip install ipykernel</code> I get the following error and warning:</p>
<pre><code>(env) jupyter@vm-53721647-831e-4ef4-bb83-5507bc6d8b55:~/formacion_gcp_ml/DATAnowCampus_ML_IA_material/Vertex$ pip install ipykernel
Looking in indexes: https://USER:****@artifacts.cloud.xxx.com/artifactory/api/pypi/pypi-remote/simple, https://USER:****@artifacts.cloud.xxx.com/artifactory/api/pypi/arq-almaas-pypi-local/simple/
WARNING: 401 Error, Credentials not correct for https://artifacts.cloud.xxx.com/artifactory/api/pypi/pypi-remote/simple/ipykernel/
ERROR: Could not find a version that satisfies the requirement ipykernel (from versions: none)
ERROR: No matching distribution found for ipykernel
</code></pre>
<p>I thought that one possible reason is that my PASSWORD has an asterisk inside, such as <code>abcdefg*</code>, so I tried to following encodings:</p>
<ul>
<li>USER:abcdefg/*</li>
<li>USER:abcdefg\*</li>
<li>USER:abcdefg'/*'</li>
<li>USER:abcdefg'\*'</li>
<li>USER:abcdefg%2A</li>
</ul>
<p>But nothing.</p>
<p>In the documentation I get that <code>%2A</code> should work: <a href="https://pip.pypa.io/en/stable/topics/authentication/" rel="nofollow noreferrer">https://pip.pypa.io/en/stable/topics/authentication/</a></p>
<p>Any workaround? Changing password is quite a problem right now.</p>
<p>Please let me know is more information is needed.</p>
 

Latest posts

Online statistics

Members online
0
Guests online
5
Total visitors
5
Top