OiO.lk Community platform!

Oio.lk is an excellent forum for developers, providing a wide range of resources, discussions, and support for those in the developer community. Join oio.lk today to connect with like-minded professionals, share insights, and stay updated on the latest trends and technologies in the development field.
  You need to log in or register to access the solved answers to this problem.
  • You have reached the maximum number of guest views allowed
  • Please register below to remove this limitation

OpenAI Whisper Cannot Import Numpy

  • Thread starter Thread starter Digglit
  • Start date Start date
D

Digglit

Guest
I am trying to run the OpenAI Whisper model but running into the following error when trying to run my script:

ValueError: Unable to compare versions for numpy>=1.17: need=1.17 found=None. This is unusual. Consider reinstalling numpy.

I have, as the error suggests, tried reinstalling Numpy but that didn't solve anything. When I run the command 'pip show numpy' I get:

Code:
Name: numpy
Version: 1.23.5
Summary: NumPy is the fundamental package for array computing with Python.
Home-page: https://www.numpy.org
Author: Travis E. Oliphant et al.
Author-email: 
License: BSD
Location: /opt/homebrew/lib/python3.10/site-packages
Requires: 
Required-by: contourpy, matplotlib, pandas, pythran, scipy, transformers, whisper

So not only do I have Numpy version 1.23.5 (>1.17), it also lists whisper as dependent on the package.

My machine is a Macbook Air M1 running OS Ventura 13.0.1.

I have looked through the OpenAI github for similar issues but I can't seem to find anything of the sort. I also tried importing the package manually with this following:

Code:
import sys
sys.path.append('/opt/homebrew/lib/python3.10/site-packages/numpy')

But this didn't work either. Please let me know if you have any insight as to why this may be happening.
<p>I am trying to run the OpenAI Whisper model but running into the following error when trying to run my script:</p>
<blockquote>
<p>ValueError: Unable to compare versions for numpy>=1.17: need=1.17 found=None. This is unusual. Consider reinstalling numpy.</p>
</blockquote>
<p>I have, as the error suggests, tried reinstalling Numpy but that didn't solve anything. When I run the command 'pip show numpy' I get:</p>
<pre><code>Name: numpy
Version: 1.23.5
Summary: NumPy is the fundamental package for array computing with Python.
Home-page: https://www.numpy.org
Author: Travis E. Oliphant et al.
Author-email:
License: BSD
Location: /opt/homebrew/lib/python3.10/site-packages
Requires:
Required-by: contourpy, matplotlib, pandas, pythran, scipy, transformers, whisper
</code></pre>
<p>So not only do I have Numpy version 1.23.5 (>1.17), it also lists whisper as dependent on the package.</p>
<p>My machine is a Macbook Air M1 running OS Ventura 13.0.1.</p>
<p>I have looked through the OpenAI github for similar issues but I can't seem to find anything of the sort. I also tried importing the package manually with this following:</p>
<pre><code>import sys
sys.path.append('/opt/homebrew/lib/python3.10/site-packages/numpy')
</code></pre>
<p>But this didn't work either. Please let me know if you have any insight as to why this may be happening.</p>
 

Latest posts

Online statistics

Members online
0
Guests online
2
Total visitors
2
Ads by Eonads
Top