OiO.lk Community platform!

Oio.lk is an excellent forum for developers, providing a wide range of resources, discussions, and support for those in the developer community. Join oio.lk today to connect with like-minded professionals, share insights, and stay updated on the latest trends and technologies in the development field.
  You need to log in or register to access the solved answers to this problem.
  • You have reached the maximum number of guest views allowed
  • Please register below to remove this limitation

Not able to use the extension in the SageMaker Studio Code Editor in VPC-only mode

  • Thread starter Thread starter ezail
  • Start date Start date
E

ezail

Guest
I recently updated to the new experience of SageMaker Studio. When I opened the code editor, the extensions that are pre-installed in the official image were grayed out and unusable, as shown in the image below. Additionally, I cannot install new extensions.

enter image description here My setup:

  • SageMaker Studio is in VPC-only mode.
  • It is associated with a private subnet.
  • The private subnet is connected to a NAT gateway, which is further connected to a VPC firewall that blocks communication with external domains, except for a few allowed ones.

Questions:

  • When I associated the subnet without a firewall, the extensions worked fine. Should I add anything to the firewall's allowlist to make the extensions work?
  • The firewall seems to be the main cause, but I believe the pre-installed extensions, like Python, should not require internet communication and should not be affected by the firewall. Are there any other settings I need to adjust?
  • On the extensions page, there are sections labeled "XXXX.sagemaker.aws-installed" and "browser-installed." Could the issue be that it is not connected to "sagemaker.aws"?

Other tries:

  • I pre-installed extensions in a custom image, but they do not work properly either, exhibiting the same issues as mentioned above.
  • I also tried adding sagemaker.aws and .visualstudio.com to the firewall's allowlist, but it did not resolve the issue.
<p>I recently updated to the new experience of SageMaker Studio. When I opened the code editor, the extensions that are pre-installed in the official image were grayed out and unusable, as shown in the image below. Additionally, I cannot install new extensions.</p>
<p><a href="https://i.sstatic.net/65dScSLB.png" rel="nofollow noreferrer"><img src="https://i.sstatic.net/65dScSLB.png" alt="enter image description here" /></a>
My setup:</p>
<ul>
<li>SageMaker Studio is in VPC-only mode.</li>
<li>It is associated with a private subnet.</li>
<li>The private subnet is connected to a NAT gateway, which is further connected to a VPC firewall that blocks communication with external domains, except for a few allowed ones.</li>
</ul>
<p>Questions:</p>
<ul>
<li>When I associated the subnet without a firewall, the extensions worked fine. Should I add anything to the firewall's allowlist to make the extensions work?</li>
<li>The firewall seems to be the main cause, but I believe the pre-installed extensions, like Python, should not require internet communication and should not be affected by the firewall. Are there any other settings I need to adjust?</li>
<li>On the extensions page, there are sections labeled "XXXX.sagemaker.aws-installed" and "browser-installed." Could the issue be that it is not connected to "sagemaker.aws"?</li>
</ul>
<p>Other tries:</p>
<ul>
<li>I pre-installed extensions in a custom image, but they do not work
properly either, exhibiting the same issues as mentioned above.</li>
<li>I also tried adding sagemaker.aws and .visualstudio.com to the
firewall's allowlist, but it did not resolve the issue.</li>
</ul>
Continue reading...
 

Online statistics

Members online
0
Guests online
4
Total visitors
4
Top