OiO.lk Community platform!

Oio.lk is an excellent forum for developers, providing a wide range of resources, discussions, and support for those in the developer community. Join oio.lk today to connect with like-minded professionals, share insights, and stay updated on the latest trends and technologies in the development field.
  You need to log in or register to access the solved answers to this problem.
  • You have reached the maximum number of guest views allowed
  • Please register below to remove this limitation

local dev, Application Default Credentials not found (GCP)

  • Thread starter Thread starter Razi Melliti
  • Start date Start date
R

Razi Melliti

Guest
working on a kotlin api that call some endpoints on gcp, when I use postman or terminal to call the endpoint I get the following error:

java.lang.IllegalStateException: java.io.IOException: Your default credentials were not found. To set up Application Default Credentials for your environment, see https://cloud.google.com/docs/authentication/external/set-up-adc.

things I did:


note: this issue is happening on Mac, apparently on linux it is working fine
<p>working on a kotlin api that call some endpoints on gcp, when I use postman or terminal to call the endpoint I get the following error:</p>
<p><code>java.lang.IllegalStateException: java.io.IOException: Your default credentials were not found. To set up Application Default Credentials for your environment, see https://cloud.google.com/docs/authentication/external/set-up-adc.</code></p>
<p><strong>things I did:</strong></p>
<ul>
<li><strong>I have tried following this document</strong>: <a href="https://cloud.google.com/docs/authentication/provide-credentials-adc#local-dev" rel="nofollow noreferrer">https://cloud.google.com/docs/authentication/provide-credentials-adc#local-dev</a></li>
<li><strong>gcloud auth application-default login</strong>: Credentials saved to file [.../.config/gcloud/application_default_credentials.json]</li>
<li><strong>used a service account.</strong></li>
</ul>
<p>note: this issue is happening on Mac, apparently on linux it is working fine</p>
Continue reading...
 

Latest posts

U
Replies
0
Views
1
user2774120
U
P
Replies
0
Views
1
Pramod Karandikar
P
Top