OiO.lk Community platform!

Oio.lk is an excellent forum for developers, providing a wide range of resources, discussions, and support for those in the developer community. Join oio.lk today to connect with like-minded professionals, share insights, and stay updated on the latest trends and technologies in the development field.
  You need to log in or register to access the solved answers to this problem.
  • You have reached the maximum number of guest views allowed
  • Please register below to remove this limitation

How to restrict Emmet suggestions to only JSX code in `javascriptreact` files in VS Code?

  • Thread starter Thread starter Eternal 404
  • Start date Start date
E

Eternal 404

Guest
I'm using Visual Studio Code for React development and I want Emmet suggestions to appear only when I'm writing JSX code, not regular JavaScript, in javascriptreact files (.js, .ts, .jsx or .tsx).

Issue I'm facing: See this image to see my actual problem

I don't want to see the Emmet abbreviation while writing javascript, because there is no any use of it and it just increasing my worktime.

Despite configuring my settings.json like this:

Code:
{
    "emmet.includeLanguages": {
        "javascriptreact": "html"
    },
    "emmet.triggerExpansionOnTab": true
}

I still get Emmet suggestions while writing JavaScript code.

Is there a way to restrict Emmet suggestions to only JSX parts of javascriptreact files in VS Code? Any tips or additional configurations would be greatly appreciated.

<p>I'm using Visual Studio Code for React development and I want Emmet suggestions to appear only when I'm writing JSX code, not regular JavaScript, in javascriptreact files (.js, .ts, .jsx or .tsx).</p>
<p>Issue I'm facing:
<a href="https://i.sstatic.net/MBzWteKp.png" rel="nofollow noreferrer">See this image to see my actual problem</a></p>
<p>I don't want to see the <strong>Emmet abbreviation</strong> while writing javascript, because there is no any use of it and it just increasing my worktime.</p>
<p>Despite configuring my settings.json like this:</p>
<pre><code>{
"emmet.includeLanguages": {
"javascriptreact": "html"
},
"emmet.triggerExpansionOnTab": true
}
</code></pre>
<p>I still get Emmet suggestions while writing JavaScript code.</p>
<p>Is there a way to restrict Emmet suggestions to only JSX parts of javascriptreact files in VS Code? Any tips or additional configurations would be greatly appreciated.</p>
 

Latest posts

Top