OiO.lk Community platform!

Oio.lk is an excellent forum for developers, providing a wide range of resources, discussions, and support for those in the developer community. Join oio.lk today to connect with like-minded professionals, share insights, and stay updated on the latest trends and technologies in the development field.
  You need to log in or register to access the solved answers to this problem.
  • You have reached the maximum number of guest views allowed
  • Please register below to remove this limitation

Error with ruby version on termux when I try to install metasploit

  • Thread starter Thread starter Nicolas Martinez
  • Start date Start date
N

Nicolas Martinez

Guest
I was installing metasploit with termux and it said: termux output

Code:
~ $ ls <br>
metasploit-framework  storage  wiki-termux<br>
~ $ cd metasploit-framework<br>
~/metasploit-framework $ ruby msfconsole<br>
Could not find Ascii85-1.1.0 in any of the sources<br>
Run bundle install to install missing gems.<br>
~/metasploit-framework $ bundle install<br>
Fetching gem metadata from https://rubygems.org/.........<br>
pcaprub-0.13.0 requires ruby version ~> 2.0, which is incompatible with the<br>
current version, ruby 3.0.0p0<br>

And if I try to install metaploit directly:

termux output

Code:
~ $ ls
metasploit-framework  storage  wiki-termux <br>
~ $ cd metasploit-framework <br>
~/metasploit-framework $ msfconsole <br>
The program msfconsole is not installed. Install it by executing: <br>
 pkg install metasploit <br>
~/metasploit-framework $ pkg install metasploit <br>
Checking availability of current mirror: ok <br>
Get:2  https://ipfs.io/ipns/k51qzi5uqu5dj05z8mr958kwvrg7a0wqouj5nnoo5uqu1btnsljvpznfaav9nk unstable InRelease [14.0 kB]<br>
Get:3 https://ipfs.io/ipns/k51qzi5uqu5dgu3homski160l4t4bmp52vb6dbgxb5bda90rewnwg64wnkwxj4 x11 InRelease [14.0 kB]<br>
Get:1 https://10.via0.com/ipns/k51qzi5uqu5dg9vawh923wejqffxiu9bhqlze5f508msk0h7ylpac27fdgaskx stable InRelease<br>
Hit:4 https://grimler.se/game-packages-24 games InRelease <br>
Hit:5 https://grimler.se/science-packages-24 science InRelease <br>
Fetched 42.0 kB in 4s (10.9 kB/s) <br>
Reading package lists... Done <br>
Building dependency tree... Done <br>
Reading state information... Done <br>
All packages are up to date. <br>
Reading package lists... Done <br>
Building dependency tree... Done <br>
Reading state information... Done <br>
E: Unable to locate package metasploit <br>
<p>I was installing metasploit with termux and it said:
<a href="https://i.sstatic.net/NlgJn.jpg" rel="nofollow noreferrer">termux output</a></p>
<pre><code>~ $ ls <br>
metasploit-framework storage wiki-termux<br>
~ $ cd metasploit-framework<br>
~/metasploit-framework $ ruby msfconsole<br>
Could not find Ascii85-1.1.0 in any of the sources<br>
Run bundle install to install missing gems.<br>
~/metasploit-framework $ bundle install<br>
Fetching gem metadata from https://rubygems.org/.........<br>
pcaprub-0.13.0 requires ruby version ~> 2.0, which is incompatible with the<br>
current version, ruby 3.0.0p0<br>
</code></pre>
<p>And if I try to install metaploit directly:</p>
<p><a href="https://i.sstatic.net/FqgsM.jpg" rel="nofollow noreferrer">termux output</a></p>
<pre><code>~ $ ls
metasploit-framework storage wiki-termux <br>
~ $ cd metasploit-framework <br>
~/metasploit-framework $ msfconsole <br>
The program msfconsole is not installed. Install it by executing: <br>
pkg install metasploit <br>
~/metasploit-framework $ pkg install metasploit <br>
Checking availability of current mirror: ok <br>
Get:2 https://ipfs.io/ipns/k51qzi5uqu5dj05z8mr958kwvrg7a0wqouj5nnoo5uqu1btnsljvpznfaav9nk unstable InRelease [14.0 kB]<br>
Get:3 https://ipfs.io/ipns/k51qzi5uqu5dgu3homski160l4t4bmp52vb6dbgxb5bda90rewnwg64wnkwxj4 x11 InRelease [14.0 kB]<br>
Get:1 https://10.via0.com/ipns/k51qzi5uqu5dg9vawh923wejqffxiu9bhqlze5f508msk0h7ylpac27fdgaskx stable InRelease<br>
Hit:4 https://grimler.se/game-packages-24 games InRelease <br>
Hit:5 https://grimler.se/science-packages-24 science InRelease <br>
Fetched 42.0 kB in 4s (10.9 kB/s) <br>
Reading package lists... Done <br>
Building dependency tree... Done <br>
Reading state information... Done <br>
All packages are up to date. <br>
Reading package lists... Done <br>
Building dependency tree... Done <br>
Reading state information... Done <br>
E: Unable to locate package metasploit <br>
</code></pre>
Continue reading...
 
Top