OiO.lk Community platform!

Oio.lk is an excellent forum for developers, providing a wide range of resources, discussions, and support for those in the developer community. Join oio.lk today to connect with like-minded professionals, share insights, and stay updated on the latest trends and technologies in the development field.
  You need to log in or register to access the solved answers to this problem.
  • You have reached the maximum number of guest views allowed
  • Please register below to remove this limitation

Error installing Exempi 2.5.2 on M1 Macbook Pro running Big Sur

  • Thread starter Thread starter dromalpalli
  • Start date Start date
D

dromalpalli

Guest
I'm trying to install Exempi 2.5.2 in PyCharm IDE for python in order to read Metadata from a Photoshop psd file.

My code is:

Code:
import PIL
from libxmp.utils import file_to_dict
from libxmp import consts
from psd_tools import PSDImage

if __name__ == '__main__':
    print('Hello')

I have installed the following packages in PyCharm: ExifRead Pillow PyBundle brew docopt packbits pip psd-tools3 python-xmp-toolkit pytz setuptools

I get the following Errors: Traceback (most recent call last):

File "/Users/rajnesh/Python/uploadJpeg2SquareSpace.py", line 9, in from libxmp.utils import file_to_dict

File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/libxmp/init.py", line 50, in from .core import XMPMeta, XMPIterator

File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/libxmp/core.py", line 50, in from . import exempi as _cexempi

File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/libxmp/exempi.py", line 69, in EXEMPI = _load_exempi()

File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/libxmp/exempi.py", line 60, in _load_exempi

raise ExempiLoadError('Exempi library not found.')

libxmp.ExempiLoadError: Exempi library not found.

Process finished with exit code 1

The Documentation for Exempi says that I need to have Boost installed. I wonder whether this is the problem. I'm not sure how to install it in PyCharm, since I don't see it as an option amongst the packages.
<p>I'm trying to install <a href="https://python-xmp-toolkit.readthedocs.io/en/latest/installation.html" rel="nofollow noreferrer">Exempi 2.5.2</a> in <strong>PyCharm IDE</strong> for python in order to read Metadata from a Photoshop psd file.</p>
<p><strong>My code is:</strong></p>
<pre><code>import PIL
from libxmp.utils import file_to_dict
from libxmp import consts
from psd_tools import PSDImage

if __name__ == '__main__':
print('Hello')
</code></pre>
<p><strong>I have installed the following packages in PyCharm:</strong>
ExifRead
Pillow
PyBundle
brew
docopt
packbits
pip
psd-tools3
python-xmp-toolkit
pytz
setuptools</p>
<p><strong>I get the following Errors:</strong>
Traceback (most recent call last):</p>
<p>File "/Users/rajnesh/Python/uploadJpeg2SquareSpace.py", line 9, in
from libxmp.utils import file_to_dict</p>
<p>File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/libxmp/<strong>init</strong>.py", line 50, in
from .core import XMPMeta, XMPIterator</p>
<p>File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/libxmp/core.py", line 50, in
from . import exempi as _cexempi</p>
<p>File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/libxmp/exempi.py", line 69, in
EXEMPI = _load_exempi()</p>
<p>File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/libxmp/exempi.py", line 60, in _load_exempi</p>
<p>raise ExempiLoadError('Exempi library not found.')</p>
<p>libxmp.ExempiLoadError: Exempi library not found.</p>
<p>Process finished with exit code 1</p>
<p><strong>The Documentation for <a href="https://python-xmp-toolkit.readthedocs.io/en/latest/installation.html" rel="nofollow noreferrer">Exempi</a> says that I need to have <a href="https://www.boost.org/" rel="nofollow noreferrer">Boost</a> installed.</strong> I wonder whether this is the problem. I'm not sure how to install it in PyCharm, since I don't see it as an option amongst the packages.</p>
 

Latest posts

Top