OiO.lk Community platform!

Oio.lk is an excellent forum for developers, providing a wide range of resources, discussions, and support for those in the developer community. Join oio.lk today to connect with like-minded professionals, share insights, and stay updated on the latest trends and technologies in the development field.
  You need to log in or register to access the solved answers to this problem.
  • You have reached the maximum number of guest views allowed
  • Please register below to remove this limitation

Could not build wheels for _ which use PEP 517 and cannot be installed directly

  • Thread starter Thread starter Sean Payne
  • Start date Start date
S

Sean Payne

Guest
I am trying to install a package which uses PEP 517. The newest version of Pip won't allow me to install it due to an error involving building wheels for PEP 517.

In the past, I've solved this issue by downgrading Pip, installing the package and upgrading Pip back to the latest version. However, after I downgrade pip in my virtualenv, if I try to run pip install black I get the error

No module named 'pip._internal.cli.main'

How can I solve this?
<p>I am trying to install a package which uses PEP 517. The newest version of Pip won't allow me to install it due to an error involving building wheels for PEP 517.</p>
<p>In the past, I've solved this issue by downgrading Pip, installing the package and upgrading Pip back to the latest version. However, after I downgrade pip in my virtualenv, if I try to run <code>pip install black</code> I get the error</p>
<blockquote>
<p>No module named 'pip._internal.cli.main'</p>
</blockquote>
<p>How can I solve this?</p>
 

Latest posts

Online statistics

Members online
1
Guests online
2
Total visitors
3
Top