OiO.lk Community platform!

Oio.lk is an excellent forum for developers, providing a wide range of resources, discussions, and support for those in the developer community. Join oio.lk today to connect with like-minded professionals, share insights, and stay updated on the latest trends and technologies in the development field.
  You need to log in or register to access the solved answers to this problem.
  • You have reached the maximum number of guest views allowed
  • Please register below to remove this limitation

Azure Deleting a function

  • Thread starter Thread starter Leo Torres
  • Start date Start date
L

Leo Torres

Guest
I am trying to delete a function app so that I can recreate it but when I try to recreate it says it already exists

This is the command I used to delete app

Code:
az functionapp delete --name MyFunctionApp --resource-group azure-functions

Then I listed the fucntions list and it returned nothing since I have no other functions.

Code:
az functionapp list --output table

I even went as far as to delete the resource group where function resides. The resource group is gone

Code:
az group delete --name azure-functions

Yet when I try to run this code I get an error

Code:
az functionapp create --resource-group azure-functions2 --consumption-plan-location eastus --runtime python --runtime-version 3.11 --functions-version 4 --name MyFunctionApp --storage-account azurefunctions --os-type Linux

Error output

Code:
Website with given name MyFunctionApp already exists.

I can probably create one with a new name yes but I rather make sure I have cleaned house and I dont have any old loose ends that may cause confusion when I redeploy.

Is there some thing I am missing to delete somewhere. I deleted the resource that had the function I am at a loss here. I do have 1 more resource group but that has 0 functions.
<p>I am trying to delete a function app so that I can recreate it but when I try to recreate it says it already exists</p>
<p>This is the command I used to delete app</p>
<pre><code>az functionapp delete --name MyFunctionApp --resource-group azure-functions
</code></pre>
<p>Then I listed the fucntions list and it returned nothing since I have no other functions.</p>
<pre><code>az functionapp list --output table
</code></pre>
<p>I even went as far as to delete the resource group where function resides. The resource group is gone</p>
<pre><code>az group delete --name azure-functions
</code></pre>
<p>Yet when I try to run this code I get an error</p>
<pre><code>az functionapp create --resource-group azure-functions2 --consumption-plan-location eastus --runtime python --runtime-version 3.11 --functions-version 4 --name MyFunctionApp --storage-account azurefunctions --os-type Linux
</code></pre>
<p>Error output</p>
<pre><code>Website with given name MyFunctionApp already exists.
</code></pre>
<p>I can probably create one with a new name yes but I rather make sure I have cleaned house and I dont have any old loose ends that may cause confusion when I redeploy.</p>
<p>Is there some thing I am missing to delete somewhere. I deleted the resource that had the function I am at a loss here. I do have 1 more resource group but that has 0 functions.</p>
Continue reading...
 
Top